Hi Community,

 

We trigger Generate source code for all items on our on-premise system. But upon checking "\Pkg\[Our Custom Package]\Schemas" in our local directory some schemas were missing what could be the problem? Most of our source code schemas were not generated.

Like 0

Like

1 comments

Hello Fulgen,

 

Hope you're doing well.

 

Please try to perform the following actions in configurations:

1. Update database structure where needed.

2. Generate source code for all items.

3. Compile all items.

4. Flush Redis.

5. Restart the website.

This should help.

 

In case there appeared errors on the generation or compilation step, please check the logs (usually can be found in C:\Windows\Temp\Creatio\Youre_Site_Name) to find out the reason of such behavior.

 

Best regards,

Roman

Show all comments

Is it possible to delete a replacing schema when you have also created inheriting schemas based on that schema? I've tried this, and it seems to turn the inheriting schemas into being read-only, showing the following message when trying to edit them:

 

Here is an example set up for this issue:

  1. Create a replacing schema of FileDetailV2 (called FileDetailV2, as it as to be)
  2. Create a schema inheriting from FileDetailV2 (any name)
  3. Delete the replacing schema created in step 1

Once these steps have been performed, it appears the inheriting schema created in step 2 is now read-only for some reason. My expectation would be that, because the OOTB FileDetailV2 still exists, there should be no issue. Does anyone know how to resolve this?

 

Thanks,

Harvey

Like 0

Like

3 comments

Hello Harvey,

 

We do not recommend to delete schemas that are set as [Parent object] for some other schemas. It could lead to unexpected system behavior and further errors. 

Furthermore, we suggest performing  [Compile all items] and [Compile modified items] actions when deleting schemas and packages from the [Configuration] section. 

 

Best regards, 

Olga. 

Olga Avis,

 

Thanks for your reply. I think the same issue could be reached by doing step 2 first, and then creating a replacing schema of the schema that inherits from, and then realising this wasn't what you wanted so you delete the replacing schema. In this case, you could break things without knowing, since on a larger project you may not be aware of every schema which inherits from another schema.

 

Is there any way to bypass this warning message, since it doesn't describe the situation (the schema isn't 3rd party and wasn't installed from a file archive)?

 

Thanks,

Harvey

Harvey Adcock,

It seems that your schema and the package of this schema is locked and as a result you are not able to modify it. We cannot provide you with the script that unlocks the package and the schema, but you can email us at support@creatio.com and provide us with the link to the app, the name of the package and schema and we will unlock it for you.

 

Best regards,

Oscar

Show all comments

After I created a Business Process, somehow it caused my custom page "Concert Programs" to lose the list of values/records and they no longer display.  I deleted the process hoping this would fix it, but have not been able to fix the issue.  My custom page gets the error in the screenshot. (Cannot read "attribute" property of undefined) .  I investigated the code which I also have a screenshot and it appears my custom entity "UsrConcertPrograms" is missing from the list.  Can you point me in the direction to resolve?  Thank you.

Like 0

Like

1 comments

Dear Darlene, 

 

If it is dev environment or you don't have any important data created after the issue occurred, probably the best and the fastest option would be to roll back to the backup made before the issue occurred (if the site is in cloud the backups are made daily, if you have on-site installation it depends on your configuration). If rolling back is not an option for you, you can try to generate the source code for all and compile all in configuration, it may help. If the issue would still occur after that, the issue needs to be debugged to fix it: 
https://academy.creatio.com/documents/technic-sdk/7-16/client-code-debugging

As you've mentioned that your custom entity is missing most likely it is either removed completely and in this case, you can try to recreate it. Also, one of the possibilities is that the corresponding SysModule record was removed, In this case, you can restore it following the steps in the community article below (please note that most likely SysModuleEntity and SysModuleEdit records still exist, however they may have been removed as well): 

https://community.creatio.com/articles/register-custom-section-existing-object

If you would need help with this please contact support at support@creatio.com because it is hard to tell the exact root cause in your case without debugging the issue.

Show all comments

I'm getting an error popup window on the first compilation for a new application. The error is states that 1 error occurred, and to view the application logs. However, none of the logs states that any error occurred. Has anyone had this problem before?

Like 1

Like

5 comments

Vladimir Sokolov,

Thanks Vladimir,

I found more detail in the "Build" log, and as you pointed out it was a dotnet cli error. I updated the framework and dotnet core and it worked correctly!

Thanks,
Morgan

I got the same error on my first compilation - I am unsure where to check the logs.  I followed the links above and installed but still getting the comp error.  Can some point me in the right direction please?

 

Darlene,

Logs are located in temp files. Usually it is windows -> temp -> bpmonline. There will be folder with IIS application name that stores 2 folders - application logs and IIS logs. You shoyld check both to find the source of this issue. 

Vladimir Sokolov,

 

Still i am facing compilation issue after updating .Net framework also.In log files still showing .Net cli error. i was cross checked my windows update as well as installed sdk and developer pack. kindly help me to fix these issue. Thanks in advance

 

Show all comments

Hi,

Is there anyway to limit the value in integer fields? For example for Market Share, By default system allows numbers greater than 100, which is not right.

 

Thanks

Like 0

Like

1 comments
Show all comments

Hi,

i'm switching my application to development in file system mode, for that, i am following the "Basic development on the bpm'online platform Day 2"(10:30) video and "Development Guide".

After i made the necessary changes to the web.conf file and press "Compile all items"

<fileDesignMode enabled="true" />
<add key="UseStaticFileContent" value="false" />

im getting a access denied error :

"Access to the path "Terrasoft.Configuration.Dev.csproj" is denied."

I would like to know how can i run "Compile all items" without errors.

 

Like 0

Like

2 comments
Best reply

I manage to fix the problem by changing the file permissions to accept the IIS_IUSRS using the https://academy.bpmonline.com/documents/technic-sdk/7-13/development-fi… guide. (Note: To find the file i used the search engine from the windows file explorer)

I manage to fix the problem by changing the file permissions to accept the IIS_IUSRS using the https://academy.bpmonline.com/documents/technic-sdk/7-13/development-fi… guide. (Note: To find the file i used the search engine from the windows file explorer)

Dear Pedro,

Yes the solution is to edit file permissions as it is described in the Academy article you provided. Good luck in your development!

Best regards,

Oscar

Show all comments

Hi, I am trying to add a new detail in the Detail wizard but it's asking for the object and not sure how to create that.

 

Any help will be appreciated.

 

Thanks.

Like 0

Like

1 comments

Dear Aaykay,

The system may request you to choose the object where you want to add the new detail. For instance, if you choose the Accounts from the list, the detail will be referring to the Accounts object http://prntscr.com/mjc55 Here is the article for more details 

https://academy.bpmonline.com/documents/technic-sdk/7-13/creating-detai…

If you need to add a new object here is another resource that will help you out:

https://academy.bpmonline.com/documents/technic-sdk/7-13/creating-entit…

Best regards,

Dean

 

Show all comments