HI all,

I create custom sections from scratch and in section page my integration developments are working ok but in the customer Portal nothing triggered (Is not showing the option to RUN BP manually ) . It looks like is a permissions issue. I tried to activate some permissions but still not working (in console I have Error 403).

P.S. Please find attached images for more clarification.
Could you please help me to find the solution?

Thanks,

Like 0

Like

0 comments
Show all comments

Hi Creatio!

I'm creating a Customer Portal and I am phasing an issue when I try to add DCM panel into page.
Cases workflow appear on the the section page :

But when I try to logg-in as user portal (role: All portal users) Cases workflow do not appear in the Customer Portal.

In the console log I receive "response status: 403 (SecurityException)".

Please what is your suggestion to fix this issue?

Thanks,

Like 2

Like

7 comments
Best reply

Hi all,

 

I want to share with you solution that Creatio support team helped me.

You have to check in object permissions if  "Portal Users" have permission to use  "SysDcmSettings" .

Hello Aurora,

Could you please let us know what portal license do you have on this local instance?

Also, could you please verify whether this DCM object is added to those lookups in order to be visible to portal users?

 

And one last question, does it appear on the portal the DCM for the cases section?
 

 

Hello,
I am having the same problem. I added the DCM object to both lookups, and I am also having an error in the console.

I check the DCM in the cases section, and I can see it.

Hello All!

Please check the following article for steps on how to add DCM to the portal: https://community.creatio.com/articles/enable-dcm-portal-users

 

In case you would still receive the error - please contact us on support@creatio.com

As I see it - this error is not the same for all and would require an individual approach.

 

Best Regards,

Dan

Bogdan,

Hello Bogdan,

The portal license that I am using in my local instance are as in the photo attached:

Is added object of Application Form (section) but not the case object (should be with the name "Application Form case in the Portal) :

Related to the last question DCM does not appear in the portal section (but as you can see to the image attached the section of the task appear but no the stages one).

Thanks,

Denis Bidukha,

Hi Denis, 

Images attached to the link are not clear.

And another question please , this solution is available for  the latest version of Creatio ?

(I am using Creatio  v8.0)

Thanks,

 

Aurora Leka,

 

 

Hi! The pictures are not representative anyway as they are made in Old UI. The information should be still relevant though. Please check if the specific portal user has required access rights and it the object has an "SSP available " checkbox checked.

 

If that did not help - please contact Support individually for investigation to be held

 

Best Regards,

Dan

Hi all,

 

I want to share with you solution that Creatio support team helped me.

You have to check in object permissions if  "Portal Users" have permission to use  "SysDcmSettings" .

Show all comments

Hi Creatio Community,

I have a portal user connected with an account for eg, Tesla.

Now on customer portal, I have an account lookup but it is only showing the account with which the Portal User is connected to (As shown in the screenshot below).

I want to know is there any way to show every Account names in the lookup?

 

Similarly, there is a contact lookup on portal which is only showing the current portal user name (As shown in the screenshot below).

Is there any way to show every Contact names in the lookup?

Thank you.

Like 0

Like

4 comments
Best reply

Nisarg Soni,

Hi!

The problem is that the record permissions are turned on and portal users don't have any permissions there. Therefore portal users don't get access to any records. 

Please add permissions of kind (All employees -> All portal users), clear the cache, re-login under a portal user and you should see the records in the list!

 

Best regards,

Max.

Hello,

Please check the object permission for the Contact and Account for "All portal users" in the “Object permissions” section?

alonadolya,

Hi

For Contact and Account, the permission is set for "All portal users". Images attached for reference.

Nisarg Soni,

Hi!

The problem is that the record permissions are turned on and portal users don't have any permissions there. Therefore portal users don't get access to any records. 

Please add permissions of kind (All employees -> All portal users), clear the cache, re-login under a portal user and you should see the records in the list!

 

Best regards,

Max.

Max,

Hi

Thanks for the solution. It works!

Show all comments