Breakpoints and debugging server-side code not working

Hello everybody

I'm working in file-system mode in a 7.18.5 development environment.

I need to override the OnSaving method of the Account entity then I created a custom EntityEventListener (following Creatio documentation).

I followed all the instructions of Creatio documentation  to setup my Visual Studio 2019 Enterprise and my local Creatio web application (see

I worked both on "Compile into a separate assembly" package (in this case opening the package project file) and "traditional" package (in this case using the autogenerated Terrasoft.Configuration.sln solution).

When I attach to w3svc process my VS2019 (run as administrator) the breakpoints are not recognized because the symbols are not loaded. Then I force to load symbols so the breakpoints are recognized (see image below):


If I add a new break point during debug there's an error:


Anyway.. the debugging doesn't work: if I press F10 or F5 the breakpoints after the first are not manged and the execution ends.


So we have two main problems:

1) The symbols are not automatically loaded (but I can do it manually..)

2) The debugging tools dont work


I'm I doing something wrong?

I can I really debug server-side code?



Like 0



Hello Massimiliano,


As for the automated symbols download - yes, please download them manually in case automated download didn't download all the symbols.


As for the breakpoint set - unfortunately there is no standard solution for this, only those described in forums here or here.


Best regards,


Oscar Dylan,

Hello Oscar,

It seems related to the "Optimize code" option but it seems to me that Creatio compiles the packages in Release mode and not in Debug mode. Does the issue comes from that? Is there any solutions?


Best regards




<compilation debug="true" targetFramework="4.7">


          <add assembly="System.Runtime, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />




and all other settings performed in terms of the article you sent should compile packages in debug mode.


Best regards,


Dear Oscar

I tried to change that setting in both web.config files (the "root one" and the "Terrasoft.WebApp one") but it didn't work. I saw that the dll's are compiled into the "Release" folder and not into "Debug" folder.

Am I doing something wrong?

If we set "debug=true" in the web.config files, are the packages created correctly to be deployed to production environments or do we need to reset the "debud=false" and recompile before exporting the packages?

Best regards


Show all comments