Question

System.UriFormatException:

Hello all,

 

I am getting this error while restarting with CLIO.  I am not sure where to start. There is nothing in the process log.  any suggestions?

 

 

System.UriFormatException: Invalid URI: The format of the URI could not be determined.
   at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
   at System.Uri..ctor(String uriString)
   at System.Net.WebRequest.Create(String requestUriString)
   at Creatio.Client.CreatioClient.CreateRequest(String url, String requestData)
   at Creatio.Client.CreatioClient.Login()
   at Creatio.Client.CreatioClient.CreateCreatioRequest(String url, String requestData, Int32 requestTimeout)
   at Creatio.Client.CreatioClient.ExecutePostRequest(String url, String requestData, Int32 requestTimeout)
   at Clio.Common.CreatioClientAdapter.ExecutePostRequest(String url, String requestData, Int32 requestTimeout)
   at Clio.Command.RemoteCommand`1.ExecuteRemoteCommand(TEnvironmentOptions options)
   at Clio.Command.RemoteCommand`1.Execute(TEnvironmentOptions options)

 

Like 0

Like

4 comments
Best reply

Hi,

 

Please use the following command instead:

clio restart -u http://o_drobina:1025 -l Supervisor -p Supervisor

where http://o_drobina:1025 should be replaced with the URL to your app, Supervisor (-l) and Supervisor (-p) are login and password respectively.

 

Best regards,

Oscar

Hi,

 

Please use the following command instead:

clio restart -u http://o_drobina:1025 -l Supervisor -p Supervisor

where http://o_drobina:1025 should be replaced with the URL to your app, Supervisor (-l) and Supervisor (-p) are login and password respectively.

 

Best regards,

Oscar

Thanks

If I use the -e that works as well. Odd as it use to work. Thank you very much

Hi,

I wanted to know is there any clio command to reset the whole environment to its basic default state after deleting the custom development package?

Thanks

Hi,

 

No, there is no such command. You will need to redeploy the app locally using clean OOB binary files.

 

Best regards,
Oscar

Show all comments