Error while updating from SVN repository

While updating from repository in my local instance, I am getting the following error,

 

Error
An error has occurred when working with the repository
Failed to run the WC DB work queue associated with '\xxxxxxxxxxxxxxx', work item 23955 (file-install Schemas/UsrBPMCustomerOppurtunity/UsrBPMCustomerOppurtunity.cs 1 0 1 1)
SvnErrorCode: SVN_ERR_WC_BAD_ADM_LOG
RootCause: The system cannot find the path specified.

 

But there were no changes made to repository or repository path. Kindly help me with the above issue.

 

DB: Oracle 12.1.0

SVN: Visual SVN server with Tortoise SVN client

Like 0

Like

9 comments

 

 

Grigoriy,

I have a doubt regarding the commands -

delete from work_queue and svn clean up 

Could you please clarify whether running these commands will clean all work queues related to other SVN projects because there are several other projects running in the SVN server and clearing the work queue will create problems.

Hello!

 

1. You should export local changes to .md files (if there are any)
https://academy.creatio.com/documents/technic-sdk/7-16/schema-export-and-import
2. Click the "Restore from repository" button. Note, this step will revert all local changes not committed to the repository.

 

Please, let us know in case any further information is required. 

 

Best regards,

Olga. 

Olga Avis,

I have problem connecting to SVN repository so "Restore from repository" did not work. I tried this as a first step and then writing here seeking help.

I need help in how to do an SVN clean up with Visual SVN Server. I could not locate the .svn\wc.db as given in the post https://stackoverflow.com/questions/22362823/failed-to-run-the-wc-db-work-queue-associated-with-file

DhariniS,

 

The issue can be connected to the SVN repository itself.  Could you please try to use Tortoise SVN cleanup

If a Subversion command cannot complete successfully, perhaps due to server problems, your working copy can be left in an inconsistent state. In that case you need to use TortoiseSVN → Cleanup on the folder. It is a good idea to do this at the top level of the working copy.

 

Please, let us know in case it does not help you. 

 

Best regards,

Olga. 

Olga Avis,

Even after doing TotoiseSVN -> Cleanup on the folder (after check out from SVN), I am still getting the same error.

Please help.

Dear DhariniS,

 

Most probably, the issue is related to the authorization. Your saved authorization is stored by default in the C:\Windows\Temp folder, and files from there are sometimes lost. Please try changing the “sourceControlAuthPath” and “defPackagesWorkingCopyPath” parameters in ConnectionStrings on the path from where the data will not be lost (e.g., the booth folder itself). Please see the example below:

 

<add name="defPackagesWorkingCopyPath" connectionString="C:\inetpub\wwwroot\bpmOnline\Terrasoft.WebApp\Terrasoft.Configuration\Pkg" /> 

<add name="sourceControlAuthPath" connectionString="C:\inetpub\wwwroot\bpmOnline\Terrasoft.WebApp\svn" />

 

 

(The svn folder for the “sourceControlAuthPath” parameter must be created).

After that, log on to the storage through the configuration.

 

If the issue still exist, please try to find the local svn database for this package and clear the “WORK_QUEUE” table. The database is on the following path:

 

C:\Windows\Temp\<web-site number>\<IIS user>\Default\TerrasoftPackages\<Package>\.svn\wc.db.

 

Best regards,

Norton

Norton Lingard,

I tried the same but I am getting the following error on doing "Update from Repository",

 

Invalid descriptor: Could not find a part of the path 'C:\TESTUSER71\7.14.3.1686_SalesEnterprise_Marketing_ServiceEnterprise_Softkey_Oracle_ENU\Terrasoft.WebApp\Terrasoft.Configuration\Pkg\Safaricom_SFA_LeadToCash\Schemas\MobileAccountGridPageSettingsDefaultWorkplace\MobileAccountGridPageSettingsDefaultWorkplace.js'. Path: C:\TESTUSER71\7.14.3.1686_SalesEnterprise_Marketing_ServiceEnterprise_Softkey_Oracle_ENU\Terrasoft.WebApp\Terrasoft.Configuration\Pkg\Safaricom_SFA"

Attaching the screenshot here.

Dear DhariniS,

 

Unfortunately, it is difficult to determine the root cause of the issue without having an access to the instance and to the config files. Therefore, in order to resolve the issue please try to repeat all steps that were suggested in this post.

 

Best regards,

Norton

Show all comments