Article
Mobile. "Batch element not found" error during synchronization (online mode)
15:04 Mar 01, 2018
Symptoms
The mobile app cannot synchronize in online mode (but syncs fine in offline mode).
Cause
In some configurations of IIS and .NET Framework, ASP.NET avoids special characters while processing the URL. URLs containing the "$" symbol are used when integrating with OData (bpm'online mobile application). This feature can be turned in the web.config file.
Solution
Perform the following steps with system administrator rights.
- Go to the folder with the application source files (for example, C:\bpm\7.8.0.1681_SalesEnterprise_Softkey_MSSQL_ENU). The path to the folder is arbitrary, and is usually specified by the system administrator of the application.
- Using notepad, open the web.config file found in the root folder.
- Find the section (Ctrl + F).
- Add the following string to this section -
- Save the changes.
- Open the second web.config file, located in the folder with the Terrasoft.WebApp application (for example, "C:\ bpm\7.8.0.1681_SalesEnterprise_Softkey_MSSQL_ENU\Terrasoft.WebApp") and repeat steps 2-5.
- Reload the application on IIS and clean Redis.
We recommend creating backups of both web.config files before you start.
Note: This situation occurs only when using the online mode - https://academy.bpmonline.com/documents/mobile/7-13/onlineoffline-modes
Necessary conditions and possible restrictions
System administrator rights.