Article

An error occurred while retrieving system data

Symptoms

An error occurs during synchronization: The element with the identifier "90a3e9f6 -........................- 7c4aadb41f28" was not foundю

Cause

The SysLookup table is not used in desktop versions 7.5 and 7.6, but is used in the mobile application below version 7.7.1.

There are records in the SysLookup table that refer to nonexistent schemas, e.g., with such UIDs:

90A3E9F6-12D4-45B5-9122-7C4AADB41F28

A85932A3-30A5-49D7-9627-7F749A055AB7

CCF7D813-FC83-47AD-BE61-8F3B3B98A54F

E0AA5FA2-0910-478D-943B-E9C2579AD7B4

Solution

Run the following script:

UPDATE [SysLookup]
SET IsSimple = 0
WHERE IsSimple = 1
AND NOT EXISTS (select 1 from SysSchema ss WHERE ss.[UId] = SysEntitySchemaUId)

Necessary conditions and possible restrictions

Some versions of BPMonline 7.6

Mobile app version is lower than 7.7.0

Like 0

Like

Share

0 comments
Show all comments