Hy everyone,

 

I have encountered an issue where I am trying to call my webservice endpoint and I'm getting a 404 - Not found error.

I have tried calling it through a button's function and also through Postman app, but I get the same error.

There is no ..\Creatio Instance\Terrasoft.WebApp\0\rest directory where I have installed my Creatio locally.

My Creatio version is 8.0.6.3422.

 

 

Any idea how to fix this issue?

 

Like 0

Like

5 comments

Hi!

 

Have you made any recent changes to the webservice endpoint? Also, have there been any recent changes to the Creatio instance?

 

Looking forward to hearing from you!

Alla Blinova,

Hi Alla,
I haven't made any changes to the webservice endpoint since I have created it.

The process was:
1. Create the C# code object in the advanced settings

2. Code the webservice function
3. Compile the package

4. Edit the classicUI section page source code (Adding button to call the webservice)
5. Complie the package once again

 

Also, there weren't any changes regarding my Creatio instance.

Few weeks ago I had done the same steps on a cloud trial version where it worked just perfectly.

*Edit: Typo

Thanks!

 

Then we would suggest trying to call the webservice with a different record or data set to see if the issue persists.

If the issue continues, then try the source code generation and full compilation as a potential solution.

Alla Blinova,

I have tried to recomplie the individual package, then all the other packages and also tried source code generation but I had no success.

However I had a saved package where I have used a similar webservice. I installed this package on a trial cloud environment then locally.
The webservice call worked both on cloud and on local environment.

After this I exported my package which has the reported problem regarding webservice and installed it on cloud and it still doesn't work there.

 

Is there a method to check whether I have all the requirements to call the webservice, or is it possible to compare the two webservice/package components?

Hi Alla,

 

I have been able to resolve the issue.

I tried to call [Creatio instance]/0/rest/[package name]/[function call] instead of [Creatio instance]/0/rest/[webservice class]/[function call].

 

Thank you for your help.

Show all comments

Hello community

I am working with a business process using the process element [Call Web Service].
The web service configuration and the call are working correctly.
The JSON response is similar to:
{
"$ totalResults": 2,
"$ startIndex": 1,
"$ itemsPerPage": 100,
"$ resources": [
     {
      "$ clave": "t6UJ9A000001",
      "$ Static_state": 200,
      "$ etag": "Yi4EmiUg3xw =",
       "Account": {
             "$ clave": "A6UJ9A0001RU",
             "$ uuid": "00000000-0000-0000-0000-000000000000",
           }
      },
      {
      "$ clave": "t6UJ9A00000B",
      "$ Static_state": 200,
"$ etag": "wMpPUtrfgdA =",
"Account": {
"$ clave": "A6UJ9A0001RX",
"$ uuid": "00000000-0000-0000-0000-000000000000",
}
}
]
}

My goal is to iterate the JSON and finally create tickets in BPM with the source information.
Using a pre-configured page I was able to determine that the parameter where the information is returned is [#WS Step.Response body #]
How can I take this value in a Script Task and process the JSON? or what is the correct procedure to do this?
Previously I should be able to take the value of the parameter [#WS Setp.Success #] to determine if the execution was successful

Thank you!
Good weekend

Like 0

Like

1 comments

get/set a parameter value in a business process script task
var parameter1 = Get<Guid>("Parameter1");
Set("Parameter2", parameter1.ToString());
var parameter2 = Get<string>("Parameter2");

get object of type UserConnection
var userConnection = Get<UserConnection>("UserConnection");

Show all comments

Has anyone been able to use integration SaaS solutions such as Zapier or MuleSoft with bmp'online?  I realize the bmp'online is RESTful and may require some additional effort.  I am mostly focused on a one-way sync to create leads.   Hoping to find a way to hit the DataServices side of bmp'online.

Like 0

Like

1 comments

Dear Stephen,

We already have the suggestion to add the out-of-the-box integration with the services registered and passed to the appropriate team. It will be taken into consideration for the further releases. 

At the moment the integration can be created via OData/DataService in case the mentioned services have the open API. 

Lisa

Show all comments