Hi,

I have a detail that has been added on an opportunity in code, so I cannot make it read-only with the opportunity designer. How do I set up the code so that make a decimal field in the detail read-only ?

Thanks,

Damien

Like 0

Like

1 comments

Hi Damien,

 

If this is a detail with an editable list simply add this code:

"enabled": false

to the definition of the column that you need to disable (should be added to the detail page schema, not detail schema). So it should look like this:

{
				"operation": "merge",
				"name": "columnName",
				"enabled": false
				}
			},

and refresh the page.

 

Best regards,

Oscar

Show all comments

Hi Team,

 

I have created a editable GRID and added some business rule . I have added few field as read only but still i was able to edit in the editble GRID . Any idea what is causing this problem ?

 

Regards,

Sethuraghav N

Like 0

Like

1 comments

Hi Sethu, 

Unfortunately at the moment Business Rules don't work with details with editable grid. 
This is a known issue and our developers are already working to fix this issue in future releases. 

Best regards,
Yurii.

Show all comments

Hi team ,

 

Im trying to use explore out of the box editable list options in some details the check box is enabled and in some details its not enabled ,

 

Is there anywhere i can check how this is working ?

 

Like 0

Like

1 comments

Hello Sethu, 

 

I would like to suggest you to check the below articles where you can find the requested information, as well we have a lot of useful posts on community on this topic:

https://academy.creatio.com/docs/user/no-code_customization/ui_and_busi…

https://academy.creatio.com/docs/developer/elements_and_components/basi…

 

If you have any additional or specific questions, please let me know!

 

Best regards, 

Anastasiia

Show all comments