Article
Mobile app sync error. System.ArgumentException: An item with the same key has already been added
15:23 Aug 31, 2018
Symptoms
Mobile application simulator does not work. System.ArgumentException: An item with the same key has already been added
Cause
This error is not caused by incorrect changes in the application configuration.
It islikely that localized strings were added to the mobile application's manifest, which duplicates the lines from MobileApplicationManifestMobile.
Solution
Update the application to the latest version (7.5.0) or change the localized strings in the custom schema (for example, "UsrMobileApplicationManifestCustom2Schema").
For example, add the "Custom" prefix in the name of localized lines.
Necessary conditions and possible restrictions
System administrator rights