Hi Team,

 

I have been facing an error while updating the package from SVN.
It throws an error stating Schema with Unique identifier is not found.

 

Kindly guide me to resolve this issue.

Best regards,

Bhoobalan P.

Like 0

Like

1 comments

Hi Bhoobalan,

 

Please check the application logs at the moment of the issue reproduce for additional details on the error message. Additionally try generating the source code for all schemas and compiling the app in configurations before updating the package from SVN. Also this error message can state that there is a process or some logic in the package that uses the column that was deleted from some object. Try searching anything in the system using the query:

 

set nocount on
declare @name varchar(128), @substr nvarchar(4000), @column varchar(128)
declare @sql nvarchar(max),
  @newval nvarchar(max)
 
set @substr = N'BC2E7A0A-2B9E-4A10-BE73-B2FF59752ABF' --INPUT THE ID HERE
set @sql =  N''
set @newval = @substr
 
create table #rslt 
(table_name varchar(128), field_name varchar(128), value nvarchar(max))
 
declare s cursor fast_forward for select table_name from information_schema.tables where table_type = 'BASE TABLE' order by table_name
open s
fetch next from s into @name
while @@fetch_status = 0
begin
 declare c cursor fast_forward for 
 select quotename(column_name) as column_name from information_schema.columns 
   where data_type in ('text', 'ntext', 'varchar', 'char', 'nvarchar', 'char', 'sysname','uniqueidentifier') and table_name  = @name
 set @name = quotename(@name)
 open c
 fetch next from c into @column
 while @@fetch_status = 0
 begin
--   print 'Processing table - ' + @name + ', column - ' + @column
   exec('insert into #rslt select ''' + @name + ''' as Table_name, ''' + @column + ''', ' + @column + 
 ' from' + @name + ' where ' + @column + ' like ''' + @substr + '''')
   fetch next from c into @column
 end
 close c
 deallocate c
 fetch next from s into @name
end
 
select table_name as [Table Name], field_name as [Field Name], count(*) as [Found Matches] from #rslt
group by table_name, field_name
order by table_name, field_name
 
select * from #rslt order by table_name, field_name
 
drop table #rslt
close S
deallocate S

 

And check what does this query return.

 

Best regards,

Oscar

Show all comments

Hi Team,

I have been trying to add a record in one of the lookup. Upon saving I get a below error.

 

From UI, Debugged to find the below, i.e. an object is missing in the config.
But it is available in DB.

It is inferred that object is deleted in Configuration but available in DB.

Note: This error persists across the application, when I tried to save record in any section this error pop-up.

 

ViewModule.aspx

"SBLChequeBook":{

      "imageId":"026742d9-390c-4778-bc46-9fa85c42677a",

      "moduleId":"f07b0621-39c1-4269-a3e5-dd013dca1e82",

      "moduleCaption":"Cheque Book",

      "entitySchemaName":"SBLChequeBook",

      "entitySchemaUId":"f3edef5e-3b47-4fd7-89bd-34c3681a4e57",

      "sectionModule":"SectionModuleV2",

      "cardModule":"CardModuleV2",

      "hide":"true"

   },

kindly guide me to overcome this!

Best Regards,
BHoobalan P.

Like 0

Like

2 comments

Hi Bhoobalan,

 

Please delete mentioning of the deleted object from the SysModule table:

 

DELETE SysModule WHERE SysModuleEntityId = 'f07b0621-39c1-4269-a3e5-dd013dca1e82'
OR Id = 'f07b0621-39c1-4269-a3e5-dd013dca1e82'

 

and relogin to the application after that. This should completely remove all the mentions about the deleted object from the system.

 

Best regards,

Oscar

Oscar Dylan,

Thanks much!

Show all comments