Uncaught TypeError: Cannot read property 'sort' of undefined

I'm getting the error "Uncaught TypeError: Cannot read property 'sort' of undefined" in the Dev Console when trying to access the Contacts section after making some basic modifications of the Contacts section page (adding a couple of fields, including a new lookup) which is preventing anything from loading for the Contacts section. Before adding these fields it was working fine.


I saw the article for this error, but the resolution for it states it's due to an incorrect application deployment, which seems odd given the minor modifications made all through the wizard. The article also states it's for bpm'onine mobile, which I'm not using. Does anyone have a resolution/know the cause of this?

Like 0



Dear Harvey,

Try to run the same script described in the article. Since it affects both web and mobile versions, it should resolve your problem. If you are using cloud version of the application, try to install SQL console and run the script. The SQL console can be downloaded here

Best regards,


Dean Parrett,

Hi Dean,

Thanks for the reply - after posting the question I tried running the script but there was already a record with that Id in the table, so it failed based on the Id needing to be unique. I then tried copying that record out to a backup table, deleting the record from the SysLookup table, then running the script in the article (which then ran fine) but the problem persisted in the application. After checking it was still failing, I restored the record from the backup to avoid any unwanted changes.

I'm currently looking into deleting all config changes in the package to see if I can get the Contacts section to work (thankfully few in the package currently) but obviously this wouldn't be a good solution if there were more changes that would be lost! Is there anything else I could try before losing this config?



Dear Harvey,

Thank you for the reply. 

If the script could not help and you already have the record with the same ID, I'd suggest you to contact our support team via so that we could look into the issue in your particular environment and find the solution. I believe we might not be able to resolve the issue within the community thread without support team investigation.

Best regards,


Thanks Dean,

Interestingly exporting the package, deleting it, and then re-importing the package appears to have resolved the issue, but will contact support with this if it happens again.

Best Regards,


Show all comments