Question

Toolkit to setup Map view

Hi community,

 

I'm trying to install the Toolkit to setup the Map view add-on for Creatio (https://marketplace.creatio.com/app/toolkit-setup-map-view-creatio). I installed successfully the package, I created a new section called "Maps" under the "Sales" workplace. Then I went to the Advanced settings, and I opened the schema card of my "Maps" section. I edited it and replaced the Parent Object with the "BaseModulePageWithMap" like mentioned in the installation guide. When I try to add a new page to the modified section I can't see the "Map" tab. I tried almost everything, trying to disconnect / reconnect to the system, trying to modify and replacing like every schema from the base one to the "BaseModulePageWithMap" but nothing makes it work. 

 

Do you have any suggestions to help me out ?

 

Thanks a lot !
 

Like 0

Like

3 comments

Hi Jonathan.

 

 

Please clarify whether you would like to add a second page to the 'Maps' section or you cannot see the 'Maps' tab when adding a new record.

Hi Ivan, 

 

First of all, thanks for your interest to my question.

 

When I follow the steps on the installation guide of the add-on (see the screenshot) I have the following problems :

 

In the second step I can only see the Parent object "BaseModulePageWithMap" if my section was created in the Custom package. However, I can't do anything with the custom package so when I create a new package with the package above the Custom package in the dependencies (i.e. a package that has the same dependencies as the Custom one), I can't see the "BaseModulePageWithMap" Parent object.

 

My second problem is that when I go to the "created section" and want to edit the existing page or add a new one (like mentioned in step 3), I can't see the "Map" tab.

 

How could I solve these two problems ?

 

Thanks a lot for your help !

 

Hi Jonathan,

 

If you use a dedicated package to save your customizations, please add a package dependency for the OSMExtension add-on package. After that, log out of and log back into the Creatio application, then check for updates.

 

The Custom basic package inherits all package dependencies automatically.

Show all comments