Error while upgrading to version 7.18.2 with "Exchange contacts sync for Creatio" addon installed

Hi community!


I have tried to update my customer's version from 7.17.1 to 7.18.5.

Everything worked fine until version 7.18.2. The update process stopped with the following errors:


[10:51:58] List of errors occured during utility execution: 

[10:51:58] 1) Autogenerated\Src\GlbExchangeGroupHelper.GlbExchangeFolderSynchronizer.cs(52,45) error CS0029: Cannot implicitly convert type 'System.Threading.Tasks.Task' to 'Microsoft.Exchange.WebServices.Data.ContactsFolder' 

[10:51:58] 2) Autogenerated\Src\GlbExchangeGroupHelper.GlbExchangeFolderSynchronizer.cs(85,35) error CS1503: Argument 1: cannot convert from 'System.Threading.Tasks.Task' to 'Microsoft.Exchange.WebServices.Data.ContactGroup' 

[10:51:58] 3) Autogenerated\Src\GlbExchangeGroupHelper.GlbExchangeFolderSynchronizer.cs(68,41) error CS0029: Cannot implicitly convert type 'System.Threading.Tasks.Task' to 'Microsoft.Exchange.WebServices.Data.ContactGroup' 

[10:51:58] 4) Autogenerated\Src\GlbExchangeGroupHelper.GlbExchangeFolderSynchronizer.cs(98,45) error CS0029: Cannot implicitly convert type 'System.Threading.Tasks.Task' to 'Microsoft.Exchange.WebServices.Data.ContactGroup' 

[10:51:58] 5) Autogenerated\Src\GlbExchangeGroupHelper.GlbExchangeFolderSynchronizer.cs(163,48) error CS0029: Cannot implicitly convert type 'System.Threading.Tasks.Task' to 'Microsoft.Exchange.WebServices.Data.ContactsFolder' 

[10:51:58] 6) Autogenerated\Src\GlbExchangeGroupHelper.GlbExchangeFolderSynchronizer.cs(134,45) error CS0029: Cannot implicitly convert type 'System.Threading.Tasks.Task' to 'Microsoft.Exchange.WebServices.Data.ContactGroup' 


The errors are coming from the following marketplace addon: Exchange contacts sync for Creatio | Creatio Marketplace


From the release notes, I found out that there was a net standard change in the exchange sync feature in version 7.18.2.


The logfile also states that the file Microsoft.Exchange.WebServices.dll is missing in the directory Terrasoft.WebApp\Terrasoft.Configuration\Lib. Instead, the file Microsoft.Exchange.WebServices.NETStandard.dll is now there.

I tried copying the DLL from the backup into this directory, but it didn't solve the problem.


I also tried regenerating and rebuilding with the WorkspaceConsole, but since the addon is still installed, the errors are still there.

I haven't found a way to remove packages with the WorkspaceConsole (at least it's not documented). I know clio can do this, but since the web app is nonfunctional, I guess this is no option.


Any ideas are very much appreciated!





Like 0



Hi Robert!

We reviewed this add-on and unpublished it as it has installation issues in the latest Creatio version.

To upgrade successfully on 7.18.2:

1. Delete this package from the configuration using the "Installed applications" section.

2. Re-generate the schema source code.

3. Recompile Creatio.

Then you can update Creatio.

Show all comments