Custom section and table SysEmpty

Hi

I created a custom section and I use it for filtering on a contact lookup in case portal page.

The search returns an empty result because the query use the SysEmpty table, not my custom section table.

I give all permission on the custom sectio for the portal users, but nothing change.

What am I doing wrong?

Like 0

Like

2 comments

Hi Stefano,

 

There might be multiple causes of this behavior.
First of all please keep in mind that access rights might be inherited and since your custom section is based on Contact lookup - permissions are checked for Contacts as well as for your Custom section. 

 

We also recommend looking at the SysSSPEntitySchemaAccessList table. There should be a record of the schema with which you have a problem. For portal users, by default, all schemas are considered to be administered and inaccessible. In order that portal users can use them, this schema must be in the lookup (the list of objects available to portal users). In other words - it must be in the SysSSPEntitySchemaAccessList table. After adding this schema to this table, the problem should be solved.

 

Should the above trouble-shooting not resolve your issue - please send us an email with detailed explanations of your problem to support@creatio.com so we may inspect and analyze your specific case (as it is too few details available by now and further evaluation will be required for precise solution)

 

Best Regards,
Dan

Denis Bidukha,

Thank you very much, for your suggestion.

Adding the missing record in the SysSSPEntitySchemaAccessList table solved my problem.

Show all comments