How can I add a parameter of type object (non-array) to the "Call Web Service" integration tool for a SOAP request?

Hi Community,


I'm having troubles generating a request with the following XML body, using the "Call Web Service" integration tool.

<soapenv:Envelope xmlns:soap="" xmlns:cam="" xmlns:soapenv="">
	<soapenv:Header />

Basically, when I tried to add the necessary parameters for the request, I've noticed that I can't add an object parameter without defining it as an array.

This setting is blocking me from following the structure of the request above. Because the "request" parameter is not an array. I also tried to import the wsdl, and it didn't work either.


Is there a way to bypass this? Should I create a script task instead?


Thank you in advance.


Best Regards,

Pedro Pinheiro

Like 1





You can create this service manually.

Because this is an OOTB behavior with the value "is array".

Hi Kalymbet Anastasia,


Sorry, but I didn't understand your answer. The property "Is array" is true by default.


Do I need to create the soap request using a script task? 


Best Regards,

Pedro Pinheiro

Pedro Pinheiro,


Yes, you're right. When the request parameter is of type object the collection is considered a typed array and the checkbox is checked by default and not editable.

In this case, using a script task for the SOAP service would solve the case.


Bhoobalan Palanivelu.

Show all comments