Question

Compilation error while compiling local creatio instance

Hi Community,

 

              When I am trying to compile the local iis hosted creatio instance, I get an unknown error.
When I tried to check the logs file, unfortunately, I didn’t find any errors. I am attaching log files also. I also followed the community post https://community.creatio.com/questions/problem-while-compiling-packages.
Can you please help me to find the solution?

 

Thank you in advance.

 

Regards,

Manideep Korni

File attachments
Like 6

Like

9 comments
Best reply

Hii all,
After uninstalling all the sdks in my computer and reinstalled sdks , problem is solved.
 

Regards,

Manideep

 

Hello,
 

This issue occurs when the required components are not installed on the application server.

Please make sure you have installed all the components from the article:
https://academy.creatio.com/docs/8-0/user/on_site_deployment/net_framew…

 

 

Hi,

 

i have all the components mentioned in the article. All the instances running in my local are not working from 2 days. Before those was working fine. Is there any other way to fix this issue.

 

thank you

Try uninstalling all components and installing them again.

Korni Manideep Reddy,

 

Tyr to perform the below actions in sequence.

1. Update DB

2. Generate for all schemas

3. Compile ALL

Hii all,
After uninstalling all the sdks in my computer and reinstalled sdks , problem is solved.
 

Regards,

Manideep

 

I would like to add an important detail. Thanks Manideep Korni for provided log files. Compilation error details can be found in Build.log file. Here we can find this line:
System.UnauthorizedAccessException: Access to the path 'c:\windows\system32\inetsrv\NuGet\Migrations' is denied.
One of possible solutions is to create  'c:\windows\system32\inetsrv\NuGet\Migrations' folder and provide file system modification permissions on it to IIS_IUSRS role:

 

Dmitriy Gamora,

 

Thanks a lot for your perfect answer Dmitriy. 

 

However, I do think that this is a workaround and we should not normally have to manually create these folders.

 

Why do we have this specific issue only for one of our customers on a specific server ? (i.e. Dev & Test no problem, Production --> Access to path denied).

 

The SDKs are installed and are on the same version for all of the servers.

 

Many thanks for the answer provided.

 

Best regards,

Jonathan

 

 

Saved again today by this thread, should be added to the official FAQ ;)

This error still appears on new environments on Windows 10 and Windows 11. It turns out that creating the folder c:\windows\system32\inetsrv\NuGet\Migrations is enough to fix it even without providing access for IIS_IUSRS role.

Show all comments